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1. Overview
This manual bridges the gap between the three main programs necessary for the operation
of the LPKF® milling machine, and then gives an overview of the physical operation of
the machine. The first program in the process of milling is OrCAD® Layout, which is
responsible for setting the footprints of the parts, connecting the proper pins of the
footprints, generating a usable trace, and then creating a portable version of the circuit
layout (Gerber files). The second program in the process is CircuitCam, which takes the
Gerber files and turns them into a single LMD file. The LMD file is then imported into
the third program, BoardMaster that is in charge of the actual milling operation. All of
the programs used in this process are very complex; this manual gives just enough needed
to get going and mill a board, just scratching the surface of what can be done. Figure 1
shows a brief overview of the complete process.
This manual provides some information crucial to the proper operation of expensive
department machinery, and extreme care should be taken in order to avoid any mistakes.
Please read the entire manual before attempting milling; if nothing else AT LEAST read
the final section on milling machine operation. If at anytime throughout the process
unexplainable uncertainties or errors occur, consult the Help files in the appropriate
application, the Internet, the complete LPKF® Milling machine manuals, or one of the
professors managing the milling machine. Unless you are properly trained, do not
attempt to fix equipment on your own.
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Figure 1: Circuit design process

2. OrCAD® Layout
OrCAD® Layout is responsible for setting the component footprints and connecting the
correct pins. When all of the pins have been connected the board can be routed (which
means generating the physical traces). After the traces have been drawn, the necessary
layers can be exported as Gerber files to be sent to CircuitCAM.
There are a few important things to keep in mind during this process. First, be sure to
know ahead of time exactly what parts you will be using and what packages will contain
the parts. The physical layout of the package may be needed during the design process in
order to create a footprint for a part that is not currently stored in the Layout parts
database. Also be sure to note the metric or standard measurements for your packages.
Layout has a relatively extensive part database, and using the wrong measurements will
obviously invalidate your design. Most importantly though, WHEN YOU ARE
CONFUSED -- USE THE HELP SYSTEM. This cannot be stressed enough; the
OrCAD® help libraries are very, very helpful if you are willing to take the time to
review them.

2.1 Creating a Circuit using Layout
2.2 Make a new Design
a) To start Layout, click on the desktop icon (shown to the right), OR go
to the directory D:\Cadence\Psd_14.0\Layout_Plus and run Layout.
b) To start a new design, go to File -> New OR click the new icon.
c) In the dialog box that appears, select the “Default.TCH” template, which can be
found in the D:\Cadence\Psd_14.0\Layout_Plus\Data directory and click ‘Open’
(the rest of the template files are for layouts with predefined borders on different
sizes of paper).

d) In the next dialog box, click on ‘Cancel’. This window asks for the Netlist Source
file that can be generated from OrCAD® Capture, which is not used here.
e) This will get you into the default window, in which one can place components,
connect the necessary pins, and auto-route the board.

2.3 Place Components
a) First, go to Tool -> Component -> New OR click on the component
icon. After clicking on the icon, right click on the desktop and select
‘New’.
b) The Add Component dialog box appears.
Note:
Reference designator is the unique part
number.
Footprint is where the part footprints are
selected
Location gives the X, Y, and rotation of the
part. 100 units in the X and Y correspond to
the common 0.100 spacing found on bread
boards and DIPs.

c) To select a footprint, click on
the footprint button, and the
following dialog will appear.
Simply select the library and
footprint for the needed part.
Then press ‘OK’.
When selecting footprints, it is
helpful to have the OrCAD®
Layout Footprint Libraries
book, which shows almost all
of the footprints in true size.

d) When placing the part on the layout window, it will appear hollow and will follow
the cursor. In this state, the key r will rotate the part in 90 degree increments.
Also, the part will snap to the common 0.100 spacing. To disable the Design
Check Rule, which can substantially limit the working area, depress the DRC
icon (shown on the right as pressed/enabled).
e) After the part is placed, it can still be moved by simply clicking on it. If the part
is double-clicked the Add Element dialog will appear again and the X and Y
coordinates and the rotation can be manually changed.

2.4 Connecting Pins
a) When all of the components have been placed, the pins can be connected.
Although the pins can be connected before all the parts have been placed, it is
somewhat easier to do after.
b) To connect the pins go to Tool -> Connection-> Select or click on the following
icon.
c) Click on the pin to connect from and
a yellow line will follow the cursor.
Then click on the pin to connect to,
and the Modify Nets dialog will
appear giving the connection name.
OrCAD® calls the connections nets;
these can be viewed in a spreadsheet
if the main editing window is
minimized or by selecting View ->
Database spreadsheets... -> Nets. The above figure shows the connection between
pin 1 of one component and pin 2 of a second component.
d) To disconnect a pin from a Net, right click on the main window while the
connection tool is selected and choose ‘Disconnect Pin’ from the pop-up menu.

In addition, ‘Delete’ in the menu will delete a connection. If a connection is
attached to more than one pin when deleted, Layout will split the Net and ask for
a new net name.
e) When all of the nets have been placed, their properties must be changed in the
Nets spreadsheet, which can be found my minimizing the main editing window or
going to View -> Database spreadsheets... -> Nets. The following window shows
the Nets spreadsheet. The
color of a connection can
be changed by right
clicking on the color
coulomb and selection
‘Change Color’ from the
list.
f) By double clicking
on one of the Nets
listed, such as
NET_2 shown
above, the Edit Net
dialog will be
brought up.

g) Min Width, Conn Width, and Max Width designate the actual milling width. As a
rule of thumb, the smaller the width, the harder it is to mill with a greater chance
of error. Try to get the width as large as possible, and if the board cannot be autorouted even after components have been moved, try decreasing the width. A
width of 25 is good to start with. Another consideration for connection width is
the current carrying capacity, with larger width connections being able to carry
more current since more copper present in the trace. Through experience, a
connection width of 50 carried 1.5 Amps with little difficulty.
h) While still in the Edit Net dialog, the layers available for the connection must also
be designated. Do so by clicking on the ‘Net Layers...’ button and choose the
available layers. If a one sided copper board is being used, then only select
Bottom Layer. Conversely, if a two sided copper board is being used, then select
Top and Bottom Layer.

2.5 Placing Text
a) Placing text next to connections is often very helpful, since it can designate signal
names, voltage polarity, as well as many other things. Upon milling, the text will
show as if one was looking down to the top of the board, so if text will appear on
the bottom of the board, it will have to look backwards in the main window.
b) To place text, go to Tool -> Text -> New, or click on the following
icon. Then right click on the desktop and select new and the
following window will appear.
Note:
Test String is where the text to be placed is
written.
Layer selects the layer the text will be milled
to.
Mirrored selects whether the text will appear
backwards or not. This option is necessary if
text is placed on the bottom.
c) The text can always be edited after placing it
by double clicking on it, which brings up the
Text Edit window.

3. Creating a Circuit using
OrCAD® Schematic Capture
3.1 Build the Schematic
a) To start Capture CIS, click on the desktop icon OR go to
the directory D:\Cadence\Psd_14.0\Capture and run
Capture.
b) To start a new design, go to File -> New -> Project… OR click
the new icon.
c) In the New Project dialog box that pops up, give
your project a unique Name and Location, making
sure that the ‘Schematic’ radio button is selected.
When you are satisfied, click the ‘OK’ button to
initialize the new project and open a blank
schematic.
d) With your schematic sheet open, parts can now be
added. Use the Add Part button to bring up the
Place Part dialog box. In the event that no

libraries appear in the Libraries list, click on the ‘Add Library…’ button, highlight
all available *.olb files in the Browse File dialog, and click ‘Open’.
e) Now, in the Part text box enter the first few letters of the part name and browse
through the Part List to find the necessary part. Click ‘OK’.
f) Place the part by clicking on the schematic to add an instance of the part. When
you are finished, right click and select ‘End Mode’.
g) Power sources and other parts can be added by repeatedly accessing the Add Part
button or the Place Power or Place Ground buttons in a similar fashion.
h) Edit the part properties to change part values (i.e. resistance, capacitance, voltage,
part identifier) as necessary.
i) Wire the parts using the Place Wire or Net Alias or Place Bus buttons as
necessary (see the Help menu in Capture for more information). A completed
example is shown below.

3.2 Annotating and DRC Check
Annotating the schematic updates the variable names of each component set to ensure
unique part identification for every instance on the schematic. In other words, it prevents
you from accidentally having two resistors labeled R? by appending a unique number to
the end of the name (R? and R? Æ R1 and R2).
The DRC check will check to make sure you have all pins on your schematic wired
properly (i.e. that you haven’t accidentally connected a VCC pin to GND or wired two
input pins together).
a) To use these functions, restore down or minimize your schematic sheet and select
your project name on the project files window (your project name will be *.dsn).
This allows the project Tools menu to be used.
b) The Annotate function can be accessed by going to
Tools -> Annotate… and brings up the Annotate
dialog box.
c) Select the scope of Update entire design and the
action of Incremental reference update (see the Help
menu for more information on the use of these and
other options). Click ‘OK’ to update the design.
d) The DRC check can be accessed by going to Tools ->
Design Rules Check… and brings up the Design
Rules Check dialog box. The default selections should be adequate but be sure to
review them before selecting ‘OK’.

e) Any errors will be displayed in a new window. Fix them and re-run the check to
make sure all errors have been removed.

3.3 Importing to Layout
With the schematic completed and checked, it is time to produce a net list that can be
used to import the design into Layout.
a) To use these functions, restore down or minimize your schematic sheet and select
your project name on the project files window (your project name will be *.dsn).
This allows the project Tools menu to be used.
b) Go to Tools -> Create Netlist… to bring up the Create Netlist dialog box. Select
the tab labeled Layout. The default settings should be fine, but be sure to observe
the current values and change them as necessary for the design.
c) Click ‘OK’ to build your net list. The session log will reflect the processing and
will reveal any errors that might occur. See the Help menu for information on
these errors.
d) When the net list creation is successfully completed, the Layout application can
be started. Refer to the earlier section Creating a Circuit using Layout for more
information on how to start Layout.
e) Create the new circuit by going File-> New, and select DEFAULT.TCH as
indicated in the Creating a Circuit using Layout section. However, this time do
not be canceling the Netlist dialog box. Select the net list file *.mnl that is
associated with your project and click ‘OK’.
f) In the Save File As… dialog, give your circuit a name and click ‘OK’. The
import will begin, called the Automatic ECO Utility. It imports the footprints for
the parts contained in the schematic and associates properties as necessary. Most
likely, there will be parts that ECO cannot find footprints for – this is normal. A
pop-up dialog will ask how to handle this. Since the packaging information is on
hand (you did remember to do this, didn’t you?!) select ‘Link existing footprint to
component…’ and browse through the footprint library to find the footprint you

need for the part it is asking about. If you cannot find an appropriate package,
you will need to make one. Click ‘Create or modify footprint library…’ to make
your part (by all means, see the Help files in Layout for information on how to do
this!). Be patient, as this process may take a significant amount of time.

g) Once your design has been completely imported, you will have all of you parts
available on your main design window.

3.4 Auto-routing
There are two methods of routing nets: automatically using the Auto-Route function, or
manually using a set of routing tools provided by Layout. These methods apply to
somewhat different situations. Auto-routing can be extremely useful and can save a lot
of time for smaller circuits. But, for large or tightly packed circuits, the Auto-route
function may not be able to produce practical results. In this case manual routing will
have to be used for at least some portions of the design. Manual routing is much more
complicated (for obvious reasons) and is beyond the scope of this document. Refer to the
Layout Help menu for information or a quick search on Google or Yahoo for examples
and guidance.
a) After all nets have been placed, the board can be
auto-routed. This can sometimes be a long
process with many design changes. Since
Layout creates the physical traces automatically,
sometime it cannot figure out the best way to
place a trace, and thus gives up. The only way
to counter this is to moves some of the
footprints around until the board actually autoroutes.

b) To auto-route, go to Auto -> Auto-route -> Board and Layout will create all of the

physical traces.
c) To unroute the board in the case of a design change or added component, go to
Auto -> Unroute -> Board.
Note: If you forgot to set the net layers on all your parts, or want to auto-route a design
that was imported from OrCAD® Capture, you can go to Options->Route Strategies>Route Layers… and enable only the layers you want to the auto-route to run
connections on.

3.5 Creating Gerber Files
a) To create the Gerber files needed in CircuitCAM, go to Options -> Post Process
Settings... and the following spreadsheet will appear.

b) To create the necessary file, select the appropriate layer, right click, and select
Run Batch. After the batch has run, the Gerber file is created in addition to the
drill hole file, which is need for the drilling the holes for the component pins.
c) For a one sided copper board, the bottom layer only needs to be created. If there
is text that will appear on the top layer of a one sided board, the top layer files
must also be run. After the files are created, one can then import them into
CircuitCAM.

3.6 Creating a New Footprint
If the footprint for a unique component is not in the available libraries it is possible to
create a new footprint. First open the Library Manager by clicking this icon:
which will result in

Then select the Create New Footprint option and input a name and a unit type (English or
Metric). You can now begin creating the pin layout of the footprint. The pin layout
works on an XY coordinate system; for this reason it s helpful to have the manufacturer
dimensioned pin layout, often found in a component user manual. The program will
place the first pin at coordinates (0,0) and the name plate text:

At this point additional pins can be placed by selecting the pin icon:

. After

creating a new pin place it in the general region of its final destination. After the point is
initially placed, final placement can be made by holding the SHIFT key down and left
clicking the desired pin. The pin will appear white; next, right click on the pin and select
properties. In the window the pin’s exact XY coordinates can be entered to reposition the
pin:

After the pins are in their correct locations the final step is to add a border line to the foot
print, which gives the footprint a dividing line between the other parts in the layout. The
first step is to select the Global Layer from the pull down menu:

The Global layer allows the border to be viewed in the layout file without milling it. The

border is made by selecting the Obstacle tool from the tool bar:

. When the footprint

is completed, select save, which will require the creation of a new library or the selection
of an existing library. Now the footprint can be used in the creation of a layout file the
same as any other footprint is selected

4. CircuitCAM
CircuitCAM is the program responsible for translating the files created in Layout into
something BoardMaster can use for the milling operation.

4.1 Importing the Gerber files
a) To start CircuitCAM, go to D:\Lpkf40\Ccam\Cam.exe or double click on the
following desktop icon.
b) Once in CircuitCAM, import the needed files by going to File ->
Import... or by clicking on the follow icon and going to the
directory where the Layout project was saved. Choose either the
top or bottom layer to import first, which will be designated by a
.TOP or .BOT file extension, respectively. Once the file is chosen, the following
window will appear.
Note:
Layer is where the imported
layer type is designated, such
as TopLayer or BottomLayer.
Digits m.n must be 3 and 4
for all imported files.
Preview is used to double
check that the correct file is
being imported.
Import actually imports the
file.
c) When importing the
THRUHOLE.tap file,
designate it as DrillPlated in
the layer box.

4.2 Isolating Text and creating the .LMD file
a) Make sure the bit size of the router is correct for your corresponding milling bit.
To do this, go to Config->Job Configurations->Insulate settings, and verify that
the default top/bottom insulation bit size is @16mils.

b) By default, CircuitCAM will view text as traces to be
milled, creating an outline around the text instead of
removing the material inside the text. In order to
isolate the text, select it and then designate it as
TextTop or TextBottom accordingly in the following
window. After the designation, the text will change
color: light blue for the bottom layer and purple for
the top layer.

c) After the text has been isolated, all the layers need
to be insulated by using the following
icon.

d) After the layers are insulated, the .LMD
file used in BoardMaster can be created using the icon seen to the
right.

e) Below is an example of a completely imported and insulated board.

5. BoardMaster
The final program in the chain is BoardMaster. This program takes the .LMD file
created in CircuitCAM and uses it to control the milling machine operation.
a) To import the .LMD file, go to File -> Import -> LMD / LPR...
then choose the file that was created in CircuitCAM. It is also a
good idea to import a file called ONE.LMD, as shown to the
right, which is used to test the milling depth before the actual
design is milled.
b) Select the layer that is going to be
milled through the following
window. MillingBottom and
MillingTop are for milling the
bottom and top layer, respectively.
For the drilling, use the
DrillingPlated option.

c) Use the following tools to Move the milling machine head, move an imported file,
copy an imported file, select complete traces to be milled, select partial traces to
be milled, and zoom in, all in reference to the figure below.

d) To add a trace to be milled, use the select complete trace tool and
select the appropriate area. Then use the + tool to add the trace,
turning the trace light green as shown to the right. Selecting the
'All+' tool will select every trace in the working area.
e) Once the desired traces have been selected, use the Start
tool to initiate the actual milling. The Start tool along
with the + and All+ tools are shown in the figure to the
right.

6. Milling Machine Operation
The final step in the milling process is the physical milling of the board. The LPKF®
milling machine is controlled through BoardMaster, so this section will include a lot of
review on BoardMaster.
Before you start, a few important notes. The Depth limiter of the milling machine is not
a turn-limited device. In fact, it will not stop you from unscrewing the entire assembly
from the milling arm. So to avoid a very nasty surprise during milling, be sure to twist
the depth limiter dial (just above the milling head) as far up as possible before you begin!
Also, be sure to turn the vacuum off before changing bits; the vacuum is easily powerful
enough to suck the small set screw off the end of the hex wrench.

Caution: Never start the milling process without the vacuum on.
a) To start, turn the machine on and use the move head tool in
BoardMaster to position the head back enough to got to the white board
that is resting on top on the milling machine surface.
b) Take the white board off of the milling machine surface and lay it on the one
sided copper board. This white board will act as the template for the copper
board, so it will fit on the milling machine surface as well as provide the backing
for the copper board during the drilling stage of the milling.
c) Lay the copper board on a stable surface and clamp the white board on top of it.
Then score the copper board by
sliding a razor blade along the
edge of the white board as
shown in the figure to the right.
After scoring around the edge
of the white board, a ruler or
other straight peace of wood
can be used to score the entire
length of the copper board.
After scoring the copper board
on both sides, line up the
copper board along the edge of
a table and press down. If the
scoring is deep enough, the
copper board should separate
cleanly along the scored edge.
If the scoring is not deep
enough, there is a chance that
the copper board will not
separate properly. An option to
scoring the copper board is

cutting it with a hacksaw after the outline of the
white board is properly marked.
d) After the copper board has been cut out, then reclamp the boards together and drill the aligning
holes using a 1/8” drill bit. Make sure not to
move the board while drilling, because if it is
moved, it will not line up when placed on the
milling machine surface.

e) When the drilling is complete, lay the two boards on the milling machine surface
with the copper board on top of the white
board, copper side up. Make sure that both
boards are secured by the posts present on the
milling machine surface. Then tape all edges
of the boards to the milling machine surface
using packaging tape. Try to have the boards
as tight as can be to the milling machine
surface. The taped boards are shown in the
following diagram.

f) Before starting to mill, move the milling head
around the milling area to establish a
perimeter so that none of the taped area is
milled. Usually it is helpful to mark the
extremities of the area with ONE.LMD files
so the actual design is milled correctly. The
perimeter is shown as the taped area in the
figure to the right.

g) Before milling an ONE.LMD, select the MillingBottom option in BoardMaster
and select the trace using the select trace tool.

h) After the perimeter is found, insert the 1/8” universal cutter into the milling
machine head. The universal cutters have a green tube protecting the actual
milling tip. Insert the universal cutter far enough so that just a small amount of
the tip protrudes below the milling head, as shown to the right. To hold the
universal cutter in place, insert the set screw and tighten it in, ensuring no to over
tighten it. Then select one of the ONE.LMD traces for milling, and start the
process. After the milling is complete, check to make sure that the traces are fully

milled. If there is still copper in the
areas that are supposed to be empty, use
the dial just above the head to move the
tip down approximately 5 clicks,
repeating the process after the
adjustment. Continue until the correct
depth is set. As a rule of thumb, it is
better to start out shallow due to the ease
at which these bits break. A correctly
milled ONE.LMD is shown below.

i) After the correct depth has been set, the
final design can be milled. Mill the final
design just as the ONE.LMD, selecting
the other design. As a reminder, never
operate the milling machine without the
vacuum system on.
j) After the traces for the final design are completed,
move the milling machine head and change out the
universal cutter with the 1.0mm drill bit. Place the
drill bit at an adequate depth so the bit will pass
completely through the copper and somewhat through
the white board. This can be checked by inserting the
drill bit and pressing down on the top of the milling
machine head.
k) Select the DrillingPlated option in BoardMaster and
then select all of the drill holes using the select trace tool. Then click the start
button in BoardMaster to start4 the drilling. Again, only operate the machine
with the vacuum system on. During the drilling process,
BoardMaster may ask for different size tool, such as a
0.8mm or 1.2mm drill bit, but just keep using the 1.0mm
bit. If BoardMaster asks for a contour router, cancel the
drilling process because the 1.0mm bit will break if it is
used as a contour router.
l) After the drilling is done, cut out the final design and the process is complete.
m) If there is text to be milled on the top layer, remove all the tape from the copper
board and flip it over. After the board is flipped, then tape it down again just as
before and select the MillingTop option in BoardMaster. Select the traces just as
before and click Start.

